Format de cellules

1. Changer le type de format
Le format d’une cellule peut se définit par un clic droit sur une sélection de cellules puis onglet format :
1

Ou dans l’onglet index
2

.2. Recopie des formats
Le pinceau permet de recopier un format de cellule et sa mise en forme :
– nous sélectionnons la cellule à recopier,
– puis pinceau dans l’onglet Accueil
– et sélection des cellules ou on recopie le format.
3

La poignée de recopie va permettre aussi d’une certaine manière la recopie de format.

3. Le format date
Sur Excel,  une date se tapera sous cette forme : jj/mm/aaaa ou jj/mm/aa.
Nous sélectionnerons les cellules, puis, nous leur donnerons le format date longue ou courte.
4

Cela se complique quand on doit calculer, un intervalle de temps en deux dates, un âge par exemple.
Dès que nous comparons deux dates Excel nous retourne un nombre de jour, à condition que le format soit numérique :
5

Nous soustrayions la date d’Aujourd’hui-DN, puis nous mettons la date au format numérique et enfin nous divisons cette par 365,25 pour obtenir un âge  (0.25 pour 1/4 pour les années bissextiles).
Ensuite, nous enlèverons les décimales.

4. Le format pourcentage
Un pourcentage sur Excel peut être noté de deux façon soit :
– directement en indiquant le pourcentage dans la cellule : ex : 33%
– ou en cliquant en pourcentage directement depuis l’onglet accueil : dans ce cas il faut laisser le nombre tel qu’il est après la division, Excel s »occupant de le multiplier par 100 ex : 0,33.

6

5. Les formats spéciaux
Pour pouvoir par exemple laisser un zéro devant un code postal ou un numéro de téléphone, il suffit de transformer la cellule en format texte, cependant Excel dispose de format spécifiques :
clique droit–> format de cellule,  puis spécial.
7

6. Le format heure
Nous notons les heures sur  Excel sur ce format :   hh :mm :dd.
Il existe plusieurs formats d’heure mais pour pouvoir cumuler les heures il faut appliquer le format 37 :30 :55.
En D9, en appliquant la fonction =SOMME(D2:D8) sur l’ensemble des heures effectuées Excel renvoi le compteur à 0 au bout de 24 heures,  il faut changer le format heure 37 :30 :55, pour pouvoir cumuler :
8
9

Exercice format Excel

7. Les formats personnalisées
Sous les formats de cellules il est possible de créer ces propres formats : par exemple nous pouvons créer le format kg de cette manière : ???????????????????”kg”.
Le ? signifie un caractère et le « kg », se mettra à chaque chiffre tapé dans les cellules sous ce format.
Voir cette artickle : https://support.office.com/fr-fr/article/Cr%C3%A9er-ou-supprimer-un-format-de-nombre-personnalis%C3%A9-78f2a361-936b-4c03-8772-09fab54be7f4